Author Topic: Oil buzzer and light going off  (Read 1637 times)

Offline DMWG40

  • Members
  • *****
  • Posts: 422
Oil buzzer and light going off
« on: July 10, 2011, 05:31:27 pm »
Ok went to test drive the G today and the oil pressure buzzer
And light are going off after about 90 seconds under driving
Condition.
I recently changed the oil and filter and the oil levels seems correct
I also have a oil cooler fitted.
Anyone got any ideas ?
Also recently refitted the breather pipe to the standard hoses

Offline grantvw

  • Members
  • *****
  • Posts: 174
Re: Oil buzzer and light going off
« Reply #1 on: July 10, 2011, 05:57:34 pm »
Have you tried a new oil presure switch yet or checked the wiring to the sensor it usually breaks off

Offline DMWG40

  • Members
  • *****
  • Posts: 422
Re: Oil buzzer and light going off
« Reply #2 on: July 10, 2011, 06:53:43 pm »
Didn't get a chance
To check out only happen this afternoon
And was on way out.
Will check tomorrow after work
Where is the sensor and wires I am looking for

Offline grantvw

  • Members
  • *****
  • Posts: 174
Re: Oil buzzer and light going off
« Reply #3 on: July 10, 2011, 07:25:37 pm »
its the blue sensor that screws into the back of the head where your s/c oil feed pipe comes from it can't really be low oil presure as when you start the car from cold the oils thick so the presure is usually high in the first 5mins of running then it thins as it warms and the presure gets lower if you know what i mean

Offline G40supercharged

  • Members
  • *****
  • Posts: 236
Re: Oil buzzer and light going off
« Reply #4 on: July 10, 2011, 10:36:57 pm »
There are 2 sensors; one for low revs (low presssure range) which doesn't set the buzzer off (light only) and one for higher revs (high pressure range) which will set the light and buzzer off. The idea is the oil pressure will be lower at idle anyway so a lower pressure switch is used to detect problems. You won't hear the buzzer at idle anyway so check to see if the oil pressure light is on all the time. 

Offline Jake G 4 0

  • Members
  • *****
  • Posts: 247
  • Rebuild time almost over
Re: Oil buzzer and light going off
« Reply #5 on: July 11, 2011, 11:09:37 am »
I had this problem and I changed all the pressure sensor's etc but the problem was that a blanking plug had popped out of the oil pump causing the oil to pump straight back to the sump.

So if none of the other solution's have any effect I would pop the sump off and have a look at the pump.

Offline ereeiz

  • Members
  • *****
  • Posts: 960
Re: Oil buzzer and light going off
« Reply #6 on: July 11, 2011, 11:12:27 am »
Worth checking the strainer on the pump pickup while you're there too, they get clogged sometimes.

Offline DMWG40

  • Members
  • *****
  • Posts: 422
Re: Oil buzzer and light going off
« Reply #7 on: July 11, 2011, 01:09:40 pm »
Ok cheers all, will check out your suggestions.

the car was fine last year last time i used it and i have only moved it a few feet outside the garage and back in.
when i drained the oil and changed that.
could reconnecting the standard pipe back to the breather on the back of the engine have anything to do with this ?
as i just removed the breather mod and also plugged back in the flying sauce also.

« Last Edit: July 11, 2011, 01:14:01 pm by DMWG40 »

Offline DMWG40

  • Members
  • *****
  • Posts: 422
Re: Oil buzzer and light going off
« Reply #8 on: July 11, 2011, 08:02:40 pm »
Ok out with the car now.
No lights on when it starts. But after I just let tick over for
5 minutes nothing. But if I put my foot on the accelerator a few
Times the buzzer and light go off.
The wires to the blue switch look fine took off and cleaned.

this blue switch was on the front right hand side of switch by the dizzy, next to the black sensor, guessing this is the wrong one now after reading his.
Looks like my oil level is just over full when warm could that
Be a possible option?
ok took about half a litre of oil out and see what happens
Next
« Last Edit: July 11, 2011, 09:25:41 pm by DMWG40 »

Offline DMWG40

  • Members
  • *****
  • Posts: 422
Re: Oil buzzer and light going off
« Reply #9 on: July 11, 2011, 08:46:00 pm »
Ok that had no effect oil level says 2/3rds full
Now and still did it.
Think I have a spare oil sensor somewhere
Will check for that, anyone know
How much anew one is out of interest.
« Last Edit: July 11, 2011, 09:23:18 pm by DMWG40 »

Offline DMWG40

  • Members
  • *****
  • Posts: 422
Re: Oil buzzer and light going off
« Reply #10 on: July 11, 2011, 09:09:31 pm »
Ok looks like only got a spare black one and not the blue
I thought I had

which area you mean the one to the right or left ?
« Last Edit: July 11, 2011, 10:03:16 pm by DMWG40 »

Offline breadman

  • Members
  • *****
  • Posts: 636
  • mk2 breadvan 1341 turbo sleeper (currently snoring
Re: Oil buzzer and light going off
« Reply #11 on: July 11, 2011, 11:12:20 pm »
It's the one on the back of the head (left).
The black and blue sensors on the front right near the distributor are temperature sensors.

Offline DMWG40

  • Members
  • *****
  • Posts: 422
Re: Oil buzzer and light going off
« Reply #12 on: July 11, 2011, 11:32:03 pm »
cheers will have to look again then, looking in totally wrong place

does that russia ekta site still operate ?

Offline ereeiz

  • Members
  • *****
  • Posts: 960
Re: Oil buzzer and light going off
« Reply #13 on: July 12, 2011, 11:21:27 am »
£12 springs to mind for the pressure sensor. There's nothing to it so wouldn't be much more than that if I'm wrong.

Offline DMWG40

  • Members
  • *****
  • Posts: 422
Re: Oil buzzer and light going off
« Reply #14 on: July 12, 2011, 11:54:10 am »
thanks is it dealer part only now, or do euro parts or gsf stock it ?

anyone have the part number ?