Author Topic: indicator shenanigans..  (Read 2900 times)

Offline deevub

  • Members
  • *****
  • Posts: 24
indicator shenanigans..
« on: September 02, 2010, 10:32:01 pm »
having a peculiar intermittent issue with indicators at the moment & was wondering if any of you have had similar or heard of anything like it?

indicators work fine one minute, then the next time you try, the dash light goes on solid & there is no 'on/off' flashing going on.
then next minute, fine again..

just had MOT, she failed on hand break efficiency & fog bulb so [not too bad for 19yr old!] replaced rear shoes & new bulb, so re-test tomo, but the indicator problem wasn't picked up in the test.

any ideas?


Offline Puncharado

  • Members
  • *****
  • Posts: 446
  • Back on the road in 2010! No, 2011! Maybe.
Re: indicator shenanigans..
« Reply #1 on: September 02, 2010, 10:57:58 pm »
Dodgy relay.

Offline deevub

  • Members
  • *****
  • Posts: 24
Re: indicator shenanigans..
« Reply #2 on: September 02, 2010, 11:00:53 pm »
many thanks!

Offline PeteG40

  • Administrators
  • *****
  • Posts: 4010
  • Housewives heart throb
Re: indicator shenanigans..
« Reply #3 on: September 03, 2010, 12:32:20 am »
i had this with a dodgy stalk too

Offline AdzCM

  • Members
  • *****
  • Posts: 462
Re: indicator shenanigans..
« Reply #4 on: October 01, 2014, 01:50:31 am »
This is similar to a problem I am now having, except mine is not intermittent. I turn on the indicator and the green light stays on but no indicator.

My hazards come on though when I press the hazard lights button.

Could this be relay or indicator stalk?

If so, where is the indicator relay located and will any mk2f indicator stalk be the same?

Adrian

Offline sleag40

  • Members
  • *****
  • Posts: 348
  • Poloist
Re: indicator shenanigans..
« Reply #5 on: October 01, 2014, 06:38:18 am »
I believe all indicator switches are the same - relay should be marked 21 and can be accessed by removing the shelf under the glove box. Its clipped to the bulkhead with another relay numbered 53. Hope this helps!

Offline AdzCM

  • Members
  • *****
  • Posts: 462
Re: indicator shenanigans..
« Reply #6 on: October 01, 2014, 03:21:58 pm »
I believe all indicator switches are the same - relay should be marked 21 and can be accessed by removing the shelf under the glove box. Its clipped to the bulkhead with another relay numbered 53. Hope this helps!

Thats perfect mate, thank you :)




Offline AdzCM

  • Members
  • *****
  • Posts: 462
Re: indicator shenanigans..
« Reply #7 on: October 10, 2014, 05:55:32 pm »
i had this with a dodgy stalk too

replaced the relay and its still doing the same. Faint green light on all of the time. turn on the indicator and the light goes a solid bright green and stays on but the indicators do not.

Could this be the stalk?

Anything else it could be?

I've taken off the plastic surround and all of the wires. How to you remove the indicator stalk? I take it you remove the steering wheels to get at screws or something?

Thanks

Offline sleag40

  • Members
  • *****
  • Posts: 348
  • Poloist
Re: indicator shenanigans..
« Reply #8 on: October 10, 2014, 06:31:15 pm »
A short circuit can do this - if the fuse has popped theres a good chance a short is the problem.
The stalk is held on with 3 screws which the steering wheel needs to come off to get at.
Is the fuse still intact?
« Last Edit: October 10, 2014, 07:08:49 pm by sleag40 »

Offline AdzCM

  • Members
  • *****
  • Posts: 462
Re: indicator shenanigans..
« Reply #9 on: October 10, 2014, 08:54:00 pm »
Thanks for that mate.

Where is the fuse for the indicators located?

Is it in the little box in the opposite side to the battery tray?

Adrian

Offline sleag40

  • Members
  • *****
  • Posts: 348
  • Poloist
Re: indicator shenanigans..
« Reply #10 on: October 10, 2014, 08:58:18 pm »
Aye, its under the clear plastic lid - fuse number 10 I think.

Offline AdzCM

  • Members
  • *****
  • Posts: 462
Re: indicator shenanigans..
« Reply #11 on: October 10, 2014, 09:54:56 pm »
Thanks again. I'll check that now...

Offline AdzCM

  • Members
  • *****
  • Posts: 462
Re: indicator shenanigans..
« Reply #12 on: October 10, 2014, 11:19:36 pm »
You are a legend mate! That's exactly what it was.

Where the heck would you get one of those fuses lol? What rating is it even?

Thanks again!

Adrian

Offline AdzCM

  • Members
  • *****
  • Posts: 462
Re: indicator shenanigans..
« Reply #13 on: October 11, 2014, 03:29:54 am »
Scratch that. Think its an 8A ... Found a wreck of them on ebay.

Offline Jezza-7

  • Members
  • *****
  • Posts: 3832
Re: indicator shenanigans..
« Reply #14 on: January 24, 2017, 11:28:33 pm »
Bringing up a thread from the dead,

I have got a very similar problem with my car, now i checked the fuses after a previous short circuit problem and they are all fine. Im yet to swap a relay over.

I will double check, but i think when i select left or right i got no response and the light stays green. Hazards work fine and can hear the relay clicking away. I have got a spare stalk but i don’t know how that could be a potential cause?