Author Topic: Supercharger issue  (Read 832 times)

Offline Mark Millington

  • Posts: 43
Supercharger issue
« on: February 20, 2018, 12:09:14 pm »
Hello chaps

Looking for a little advice.

Just refitted my boost pipes after someone else did a boost mod on my g40. Soon realised the crankcase pressure had built up throwing oil out my filler cap. Just fitted a new one way valve on back of block as it looked blocked and diaphragm had spilt inside. Now my super charger is making a terrible racket like mettalic sound. Have isolated it to this by removing belt and starting engine and noise goes just done my alternator too so sure it's not that. Is it possible that the crankcase pressurising has caused an oil feed issue to my charger also took off the oil feed to charger and ran car and oil only trickles out is that normal or should it have more pressure

Any help appreciated Mark

Offline ereeiz

  • Members
  • *****
  • Posts: 960
Re: Supercharger issue
« Reply #1 on: February 21, 2018, 04:44:47 pm »
That train of thought makes sense to me, the charger pressure has leaked back through the one way valve, as it wasnt working as a valve it was basically a pipe. The pipe fed the pressurised air into the crank, with the easiest route to vent being your dipstick tube and filler cap.

I remember reading it was tapping like fuck when your oil beeper was beeping (but no oil light? Does this light work? Does it come on when the ign is set to on before cranking the engine?).

Do you have an oil pressure gauge or can you buy / borrow one from someone? I don't know what the inlet and outlet pressures should be and at what point (ie do you measure it at tickover for lowest pressure vs under full load at WOT and high rpm to reflect hardest running conditions......... this is what I would do personally, if there's nothing to compare to/ no need then don't do this). If you can fit a gauge before the charger, ideally at the charger oil inlet (as this would closely reflect the true value) and get a reading it at least gives you a starting point. I've lost my haynes manuals and don't have access to Autodata anymore, but someone else may be able to pipe up with the oil pressure specs?

Getting the oil up to temperature would affect the reading too. It'll be thicker when cold.

Have you opened the charger and looked inside?? If this is easier it may be best to do this, have a quick visual check, take pics and upload to here if you're not sure and again, someone will be able to help you.

Where are you located roughly? Could always borrow someone elses charger / stick yours on their car to test?

Offline Mark Millington

  • Posts: 43
Re: Supercharger issue
« Reply #2 on: February 22, 2018, 05:48:33 pm »
Hello bud thanks for the reply I thinking on the right lines juatbseems bizarre things started nearly straight after putting that pipework back on. My oil light works on dash it goes out when started. When crank pressurised didn't see light come on and only a quick beep from the buzzer as indent around the roundabout then back down the motorway. Noticed the tapping when I came off next junction  and smelt oil. It stopped tapping by the time I got home about five minutes later and hasn't tapped since. Left it in garage whilst I waited for the new valve fitted it started it and it sounded terrible and is defo from the super charger belt or something that runs from it. I have a spare standard charger but am unsure on its condition but looks standard with no porting but didn't want to run it with that as it's been sat around a while and didn't wan to damage the spare one until I had it checked over. I'm located in Southampton the charger I have on the car is a stage 4 jabba sport jobby with 65mm pulley and chip. Been told to check my toothies as apparently the guides can come loose and cause noise. Just all seems like to much of a coincidence that my charger is doing this after the oil crankcase pressure issue.

I'm fairly handy wi5h the spanners but didn't fancy pulling the charger apart as have never done one before

Mark

Offline ereeiz

  • Members
  • *****
  • Posts: 960
Re: Supercharger issue
« Reply #3 on: February 23, 2018, 12:52:59 pm »
I've been convinced my charger was going to shit itself after fitting removing my standard one and fitting a fully ported one with a cone filter.
I've also been tricked by a toothed belt noise before too, so check the tension of that (same as cambelt tension, should be able to twist it about 90degrees in the slackest part).

I've never opened one either so don't blame you for not wanting to. I'd say give it a go on your old one, especially if it needs a service anyway as it''ll be opened by whoever services it. Once you've learnt how to do it with that one, take your flowed one apart and compare. You might find a leaking seal or scored metal or something to point at the potential cause of the noise.

Offline Mark Millington

  • Posts: 43
Re: Supercharger issue
« Reply #4 on: March 21, 2018, 06:33:42 pm »
Charger is being rebuilt turns out its the loose eye being that has shit it's grease out according to ocd. He reckons that's what is causing the noise so hopefully will have it back soon

Offline PeteG40

  • Administrators
  • *****
  • Posts: 4010
  • Housewives heart throb
Re: Supercharger issue
« Reply #5 on: March 21, 2018, 07:28:04 pm »
cool!

fingers crossed thats it

Offline Mark Millington

  • Posts: 43
Re: Supercharger issue
« Reply #6 on: April 01, 2018, 04:15:05 pm »
Me too Pete been off road for 4 weeks have hardly driven it since buying it. Have loads of parts to fit even sourced and original air box and ducting from Portugal!

Offline Mark Millington

  • Posts: 43
Re: Supercharger issue
« Reply #7 on: April 23, 2018, 06:03:11 am »
Hello chaps just an update. Charger back in after rebuild noise has gone. Also isn't chucking oil about anymore after new one way valve is fitted to breather pod. Fingers crossed it is all fixed and I can get on with all the other stuff.

Thanks for the help Mark

Offline ereeiz

  • Members
  • *****
  • Posts: 960
Re: Supercharger issue
« Reply #8 on: April 23, 2018, 09:35:26 am »
Did you get an original breather pod or just a generic valve?
Was it new? If so, where from?