Author Topic: Boris' G40 ** Engine still not right **  (Read 8223 times)

Offline Boris

  • Members
  • *****
  • Posts: 135
Re: Boris' G40 ** Engine help needed **
« Reply #30 on: July 11, 2011, 09:33:13 pm »
Yep, white smoke again, head is definately warped.  >:(
On the hunt for a local company to skim it now.

Offline Boris

  • Members
  • *****
  • Posts: 135
Re: Boris' G40 ** Head warped **
« Reply #31 on: July 26, 2011, 07:40:20 pm »
ok.  Had head skimmed, changed head gasket, refitted.  Was still not running right (misfiring) and blowing smoke.

Got new w5dpo spark plugs and fitted them.  No longer misfiring, but still blowing smoke (blueish white).  Set timing with timing gun, no difference.

There is a knock coming from the engine from what sounds like cyl four.  Did a pressure test which gave me the following:

cyl 1 - 8 psi
cyl 2 - 11 psi
cyl 3 - 12 psi
cyl 4 - 9 psi

Also the oil buzzer is coming on if the car is driven for a while or if revved to 2000 rpm.  Goes off if a sharp blip is given to the throttle.

Also changed the thermostat and topped up oil. 

There is very small traces of oil in the water and white gunge in the oil, but I'm not sure if this is from prior to the head gasket being changed.

Not yet changed the coil.

Any advice for me?

Offline Puncharado

  • Members
  • *****
  • Posts: 446
  • Back on the road in 2010! No, 2011! Maybe.
Re: Boris' G40 ** Engine still not right **
« Reply #32 on: July 26, 2011, 08:22:15 pm »
Have you re-fitted the old bottom end by mistake?  :D  Worse compression than before!

Blue smoke suggests burning oil, white smoke is trying to burn coolant, so blueish white maybe a bit of both.
Everything you've said seems to point at head gasket, but as it's the same with 2 different blocks and new head gaskets maybe the head is cracked in a couple of places, causing cylinders 1 and 4 to burn oil and/or coolant.

Oil buzzer could be a dodgy pressure sender, but it could be that you actually have crap oil pressure.

Offline Boris

  • Members
  • *****
  • Posts: 135
Re: Boris' G40 ** Engine still not right **
« Reply #33 on: July 26, 2011, 08:55:02 pm »
It's driving me insane.  If the heads cracked it's not noticeable to the eye. Haven't had it pressure tested though so there's every chance. 

It could be that the block needs skimmed too.

Offline Boris

  • Members
  • *****
  • Posts: 135
Re: Boris' G40 ** Engine still not right **
« Reply #34 on: August 09, 2011, 09:31:50 pm »
Took the car to be checked out by a professional.  He's told me he thinks the charger has blown a seal due to the amount of oil in the charge pipes.  He also believes this is the cause of the bottom end giving way again due to excess oil causing pre detonation in the combustion chambers leading to the failure.

In short, I need to rebuild my charger and repair / replace the bottom end again to fix the problem.  :(

Offline Justin14100

  • Traders
  • *****
  • Posts: 792
Re: Boris' G40 ** Engine still not right **
« Reply #35 on: August 09, 2011, 09:41:40 pm »
try just a charger service at first and see how that goes.

Offline Boris

  • Members
  • *****
  • Posts: 135
Re: Boris' G40 ** Engine still not right **
« Reply #36 on: August 09, 2011, 09:55:04 pm »
Yeah, Pete's guide is gonna come in very handy  :)

The knock from the engine is worrying, but we'll see what happens.

Offline cheddarcheese

  • Members
  • *****
  • Posts: 553
  • i like boobs!
    • supercharged
Re: Boris' G40 ** Engine still not right **
« Reply #37 on: August 10, 2011, 05:00:18 pm »
boris what bs mate hope you sort it but just to let you know i have got my spare engine for sale cheap as missing a couple of peripheral bits.

Offline Boris

  • Members
  • *****
  • Posts: 135
Re: Boris' G40 ** Engine still not right **
« Reply #38 on: August 19, 2011, 09:28:57 pm »
Well the good news is that the charger is ok and only throwing out the amount of oil you'd expect without having the boost return mod done on the car. The bad news is that its still not running right after changing the coil, dizzy cap and rotor arm and cleaning out the charge pipes and intercooler. Definately a problem with the bottom end, probably piston rings.

As I can't afford to be spending any more time or money on the car (and also that I have something else lined up), I'll definately be selling it now. So if anyone's interested, pm me.  ;)