Author Topic: Fluctuating rpms on part throttle.  (Read 253 times)

Offline sleag40

  • Members
  • *****
  • Posts: 360
  • Poloist
Fluctuating rpms on part throttle.
« on: October 13, 2019, 10:54:03 am »
How do!
When the fast idle emissions test was being performed on my bog standard G40, the rpms rose and fell from 2500 to 1500 every second or so. The idle is perfect + it only happens when up to temperature - whilst warming up it doesn't happen. Before I get stuck into diagnosis, has anyone else experienced and resolved these symptoms?

Cheers, Steve

Offline sleag40

  • Members
  • *****
  • Posts: 360
  • Poloist
Re: Fluctuating rpms on part throttle.
« Reply #1 on: October 15, 2019, 06:25:36 pm »
Just to add after a quick play with it this afternoon, it seems fine under load,  I'm thinking vac leak somewhere........

Offline sleag40

  • Members
  • *****
  • Posts: 360
  • Poloist
Re: Fluctuating rpms on part throttle.
« Reply #2 on: November 03, 2019, 06:34:06 pm »
Vacuum leak not found. Symptoms persist, once the revs reach 3000, the fluctuation stops. Removing the blue temp sensor plug to put it in service mode results in a drop of revs instead of a rise. Loom test next.  :(

Offline Andy

  • Traders
  • *****
  • Posts: 1498
Re: Fluctuating rpms on part throttle.
« Reply #3 on: November 03, 2019, 06:38:45 pm »
Is your base ignition timing and idle speed set correctly?

Offline sleag40

  • Members
  • *****
  • Posts: 360
  • Poloist
Re: Fluctuating rpms on part throttle.
« Reply #4 on: November 03, 2019, 07:00:58 pm »
Indeed - they were set when the engine went back in the car after its paint job (5 years ago) This issue began during the fast idle emissions test a few weeks ago - nothing has been messed with since it was reassembled chief.

Offline PeteG40

  • Administrators
  • *****
  • Posts: 4017
  • Housewives heart throb
Re: Fluctuating rpms on part throttle.
« Reply #5 on: November 05, 2019, 09:42:12 am »
the co pot values have been known to wander in my experience - might be worth a check.

Offline sleag40

  • Members
  • *****
  • Posts: 360
  • Poloist
Re: Fluctuating rpms on part throttle.
« Reply #6 on: November 05, 2019, 06:57:45 pm »
I remembered to take my multimeter with me today!
the co pot values have been known to wander in my experience - might be worth a check.
CO pot/inlet air temp sensor and their wiring check out fine, as does the blue temp sensor. The throttle closed + WOT switches work fine when tested at the throttle body,  but I'm not getting the beep at the ECU plug (6 +11 and 6 + 15) It seems reasonable to assume that either the number 6 wire or the plug pin at either end of it are at fault.
Please note, electrical stuff is not my best subject!

Cheers, Steve