Author Topic: Dipped Beam and heated rear window not working....  (Read 82 times)

Offline alexmac738

  • Posts: 5
  • Owner of a K reg G40, currently in Lancashire
Dipped Beam and heated rear window not working....
« on: November 22, 2017, 09:56:16 pm »
Hi guys, was hoping you could help...

Got in the car the other day and the dipped beam headlights wouldn't come on. I'm having a few problems with this car but I need the lights to work! The sidelights and main beam work perfectly, it's just the dipped beam won't come on when I flick the switch. I have checked every single fuse, taken them out, checked contact points and all clean. Also changed the switch to see if it was that and still the same outcome. Also it seems that the heated rear windscreen has decided to stop working at the exact same time, seems like a weird coincidence.... Only other thing I can think of doing other than checking every bit of wire is to check relays or maybe the earths? When the dipped beam was working the engine would always dip and nearly stall when they were switched on. Checked the battery charge level and its above 12V when off and around 13.7V when running. Any help would be greatly appreciated!!!

Many thanks, Alex.

Offline PeteG40

  • Administrators
  • *****
  • Posts: 3987
  • Housewives heart throb
Re: Dipped Beam and heated rear window not working....
« Reply #1 on: November 23, 2017, 07:55:10 am »
rear screen - getting 12v across the terminals that attach to the screen when its powered??

could be earths, there aren't many on a g40.

I'd also check all your fuses.