Author Topic: Timing driving me up the wall  (Read 750 times)

Offline matthg40

  • Members
  • *****
  • Posts: 539
Timing driving me up the wall
« on: June 21, 2017, 04:00:30 pm »
I've wrote a previous thread about this problem but this has now been going on for over 3 months now.my g40 will not run properly and when it does decide to run it runs like a bag of nails.when I turn the key all that happeneds is the fuel pump primes and you can hear he hall sender click and then fuel squirt out of the injectors.both timing marks are perfectly lined up and I think the problem lies with the distrubitor and it's an ignition timing problem.the car has had new coil pack,rotary arm,distrubitor cap,leads,plugs,alternator,starter motor,lamba sensor and battery.but for some reason the car will just not do what I want it to do.the leads are in the correct order as I say my timing marks line up what else could be the problem?if anyone has any ideas please feel free to advise me as I'm going insane many thanks matt

Offline quiksilver_jake

  • Members
  • *****
  • Posts: 280
Re: Timing driving me up the wall
« Reply #1 on: June 21, 2017, 04:17:41 pm »

Offline Alexiskayak_7

  • Members
  • *****
  • Posts: 625
Re: Timing driving me up the wall
« Reply #2 on: June 21, 2017, 08:40:44 pm »
Also does your destributor has any play??
Why don't you try a second hand destributor?

Offline matthg40

  • Members
  • *****
  • Posts: 539
Re: Timing driving me up the wall
« Reply #3 on: June 22, 2017, 11:20:21 am »
Already been through the sensor guide the car ran like a dream before I changed the distributor.this all happened after I got oil in the old distributor and managed to burn the rotary arm which led to replacing both.i have also tried a spare distributor and the problem is still there.

Online randombadger69

  • Members
  • *****
  • Posts: 467
Re: Timing driving me up the wall
« Reply #4 on: June 22, 2017, 11:44:44 am »
From experience I've found the timing marks well aligned doesn't mean its correctly timed. Not sure if there was a discrepancy with the bracket manufactured for G40 models or what. Have you tried taking out the two screws holding the dizzy and rotating the dizzy whilst someone cranks it. Would give you an idea if it is out by 1 tooth.

Offline matthg40

  • Members
  • *****
  • Posts: 539
Re: Timing driving me up the wall
« Reply #5 on: June 22, 2017, 03:28:12 pm »
I've had the screws out of distributor and turned it whilst cranking and thought I'd got it running ok.come back to the car later and it won't even start again due to timing it up with a strobe light and the o and z mark.plus I don't trust the marks which is why I've used the screwdriver down the cylinder no1 trick

Offline GR40

  • Members
  • *****
  • Posts: 426
Re: Timing driving me up the wall
« Reply #6 on: June 22, 2017, 05:11:08 pm »
When timing it with the strobe light did you unplug the blue sensor? If you didn't then the car is trying to correct the timing on it's own and advancing/retarding to what it used to work before! You must time it with the blue temperature sensor unpluged.
« Last Edit: June 22, 2017, 05:12:58 pm by GR40 »

Offline matthg40

  • Members
  • *****
  • Posts: 539
Re: Timing driving me up the wall
« Reply #7 on: June 22, 2017, 06:13:49 pm »
At first unplugging the blue sensor didn't make any difference revs didn't drop or raise to 2000 so I replaced it and it then responded how it should.so I timed it up with the sensor unplugged as I was advised to do so on here and club polo forum and still having problems.so wondering what else could be the issue or issues

Offline ereeiz

  • Members
  • *****
  • Posts: 960
Re: Timing driving me up the wall
« Reply #8 on: June 30, 2017, 03:29:25 pm »
ensure the car is warmed up before altering the timing. If you're unsure how long is long enough then just leave it ticking over til the fun cuts in then out, then unplug sensor, service mode, time it and see where you're at.

Difficult to warm it up if it doesn't run, I know.

Are you handy with a multimeter? Checked earths and all that usual jazz?