Author Topic: Help. Alternator or lambs or?  (Read 733 times)

Offline BenG40 gmoNeY

  • Members
  • *****
  • Posts: 16
Help. Alternator or lambs or?
« on: April 16, 2017, 10:41:19 pm »
Hello peeps

I have an issue were my engines cuts out(battery symbol on dash flickers as it bubbles and cuts out)
when I let it idle,when I hold the revs it's fine as soon as I let it go it cuts off.
A little help from my fellow G lovers
Would be much appreciated

Thanks
Ben


Offline GR40

  • Members
  • *****
  • Posts: 426
Re: Help. Alternator or lambs or?
« Reply #1 on: April 18, 2017, 01:30:56 pm »
Check the tension of the v-belts! Something is probably slipping.

Offline ereeiz

  • Members
  • *****
  • Posts: 960
Re: Help. Alternator or lambs or?
« Reply #2 on: April 19, 2017, 12:15:28 pm »
Could be timing.

Have you done anything to it prior to it starting this? Have you done anything since?

Have you set the tickover in service mode? Don't piss about with it if it's not in service mode as it'll cause what you're describing. Not saying this is your cause, but I couldn't be arsed on one of mine, just turned the idle a bit to make it better, resulted in a barely useable car, jerky, on/off, etc.

Offline G40supercharged

  • Members
  • *****
  • Posts: 236
Re: Help. Alternator or lambs or?
« Reply #3 on: April 19, 2017, 12:50:05 pm »
The battery light coming on is just a symptom of the engine running too slowly for the alternator to work just before the engine cuts out.

Offline BenG40 gmoNeY

  • Members
  • *****
  • Posts: 16
Re: Help. Alternator or lambs or?
« Reply #4 on: April 27, 2017, 01:33:33 am »
Thanks for the advice/replies pals, but I've been a twat and didn't notice
The seriously loose throttle cable. (Stretched)
Mod G trying to idle at 5-600 rpm

Thanks

Offline ereeiz

  • Members
  • *****
  • Posts: 960
Re: Help. Alternator or lambs or?
« Reply #5 on: May 01, 2017, 11:17:02 am »
Always good when it's something like that
About 10quid and 15mins and your sorted