Author Topic: help rebuilding g-lader!!!  (Read 29 times)

Offline polog40-spain

  • Posts: 2
help rebuilding g-lader!!!
« on: October 15, 2018, 03:38:41 pm »
Hi everyone,

I'm new in this forum, let me introduce myself : (or save your time about some boring story and jump a few lines down ;) )
I own my polo coupe g40 '92 since 2013, i bought it in holland and it was imported from germany in 2002 if i remember well...
I was pretty happy with it, had some rust in the battery tray, wheel arches and spots under door panels.
Engine was fine, even knowing that the damn CO-poti was failing, never planned to change it because was running fine in cold wheater.
Few years ago, the supercharger lost pressure and i decided to rebuild myself, bought all parts(apex strings, bearings...), opened it and I couldn't remove one of the bearings, so i brought it to a garage and asked if they could do it with some removal tool, tool wouldn't fit and there was no way for them to do it, one guy was around and tried to remove it with a screwdriver and in front of my eyes he broke a piece of the case...
Since then,  supercharger was laying in a box and i had to buy another used one, the car was parked for around a year and now i have kind of the same issue, decrease on boost plus oil inside intercooler, so i assume that the supercharger needs to be serviced.

THE PROBLEM:
It is already more than 3 years since i opened the g-lader and i don't remember how to put all back together!!!
Call me stupid, but i can't figure out where goes a tiny ring. (last picture)
Could anyone guide me to the last steps?
I also attached picture from what the bastart smart-looking guy did to the case.

« Last Edit: October 15, 2018, 03:50:16 pm by polog40-spain »

Offline SamG40

  • Administrators
  • *****
  • Posts: 1091
  • Take.... on.... me....
Re: help rebuilding g-lader!!!
« Reply #1 on: Yesterday at 12:47:40 pm »

Offline polog40-spain

  • Posts: 2
Re: help rebuilding g-lader!!!
« Reply #2 on: Yesterday at 06:57:16 pm »
Have a look at this for a starter. https://www.polog40.co.uk/forum/index.php?topic=6789.0

Thanks mate, i have been searching around the forum and couldnt find anything...
Lucky of me that you guys have everything under control  :D

Peteg40 guide made me realize that i have a missing part, so i will have the disassemble the other compressor to make this one run.

Thanks for the help!!! ;)